support nehalme ex

Open discussion of PAPI.

support nehalme ex

Postby ericlew » Wed Aug 24, 2011 9:00 am

Hi,

My processor is Nehalem-ex X7550 , so I need kernel 2.6.34 or newer(as the PAPI doc said). My now linux version is CentOS5.3, 2.6.18. So I want to update the kernel to version 2.6.34 or 2.6.38, but I encount an error when input the command:


/home/paraorc/lxj/software/papi-4.1.3/src/perfctr-2.6.x/update-kernel
Error: no suitable patch found for kernel 2.6.37.6


Thanks!


Eric


PS:
+ Nehalem EX support requires kernel 2.6.34 or newer.
ericlew
 
Posts: 2
Joined: Wed Aug 24, 2011 8:54 am

Re: support nehalme ex

Postby vweaver1 » Thu Aug 25, 2011 1:46 pm

Kernel 2.6.34 or 2.6.38 should have built in "perf_event" support. You do not need to patch the kernel with perfctr.
Just recompile PAPI with perf_event support enabled.
vweaver1
 
Posts: 50
Joined: Wed Feb 17, 2010 4:02 pm


Return to General discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest