Please help! Papi 4.1.3 on Ubuntu 11

Open discussion of PAPI.

Please help! Papi 4.1.3 on Ubuntu 11

Postby KatherineP » Wed Aug 24, 2011 7:40 pm

Hi I am running Papi 4.1.3 on an Ubuntu 11 virtual machine. I can run configure and make, but it fails on the make test portion. What is the issue? And can I even use PAPI inside of a VM?

Here is the error:

$ make test
cd ctests; make CC="gcc" CC_R="gcc -pthread" CFLAGS="-I.. -g -DSTATIC_PAPI_EVENTS_TABLE -DPEINCLUDE=\"/usr/include/linux/perf_event.h\" -D_REENTRANT -D_GNU_SOURCE -DUSE_COMPILER_TLS -Wall -I/home/jonny/papi-4.1.3/src/libpfm-3.y/include -DSUBSTRATE_USES_LIBPFM -Wextra -DPAPI_NO_MEMORY_MANAGEMENT" TOPTFLAGS="-O0" SMPCFLGS="" OMPCFLGS="-fopenmp" NOOPT="" LDFLAGS=" " LDL="-ldl" LIBRARY="../libpapi.a" papi_api serial forkexec_tests overflow_tests profile_tests attach multiplex_and_pthreads shared
make[1]: Entering directory `/home/jonny/papi-4.1.3/src/ctests'
make[1]: Nothing to be done for `papi_api'.
make[1]: Nothing to be done for `serial'.
make[1]: Nothing to be done for `forkexec_tests'.
make[1]: Nothing to be done for `overflow_tests'.
make[1]: Nothing to be done for `profile_tests'.
make[1]: Nothing to be done for `attach'.
make[1]: Nothing to be done for `multiplex_and_pthreads'.
make[1]: Nothing to be done for `shared'.
make[1]: Leaving directory `/home/jonny/papi-4.1.3/src/ctests'
ctests/zero
PAPI_FP_INS is not available.
PAPI_TOT_CYC is not available.
zero.c FAILED
Line # 64
Error in PAPI_start: PAPI_EINVAL

Test case 0: start, stop.
-----------------------------------------------
Default domain is: 1 (PAPI_DOM_USER)
Default granularity is: 1 (PAPI_GRN_THR)
Using 20000000 iterations of c += a*b
-------------------------------------------------------------------------
Test type : 1
PAPI_FP_INS : 4618674515408901120
Real usec : 110290
Real cycles : 330528642
Virt usec : 65339
Virt cycles : 195951661
-------------------------------------------------------------------------
Verification: none
make: *** [test] Error 1

Please advise.
KatherineP
 
Posts: 2
Joined: Wed Aug 24, 2011 7:37 pm

Re: Please help! Papi 4.1.3 on Ubuntu 11

Postby danterpstra » Thu Aug 25, 2011 7:12 am

Most virtual hypervisors don't expose the hardware counters, so even though PAPI appropriately identifies the virtual cpu and looks like it builds correctly, it cannot access the counters. So unfortunately, for now PAPI won't run in a virtual environment. What virtual system are you using?
danterpstra
 
Posts: 63
Joined: Wed Jun 23, 2010 2:21 pm

Re: Please help! Papi 4.1.3 on Ubuntu 11

Postby KatherineP » Thu Aug 25, 2011 1:05 pm

Oh, I see. Thank you!!

I am using Ubuntu 11 in Oracle VirtualBox.
KatherineP
 
Posts: 2
Joined: Wed Aug 24, 2011 7:37 pm


Return to General discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest