all_native_events Segmentation Fault with cuda component

Open discussion of PAPI.

all_native_events Segmentation Fault with cuda component

Postby KotasCW » Tue Aug 28, 2012 8:36 am

I am in the process of installing and verifying papi 5.0.0 on an Intel Xeon E5530 computer running Ubuntu 11.04 (uname -r gives 2.6.38-11-generic). I am attempting to install PAPI with the cuda component enabled. When I attempted to run the test suite, I got a segmentation fault during ctests/all_native_events. When I went back and just ran ctests/all_native_events so that the TESTS_QUIET flag would not be set, I saw that all_native_events died after printing the message "Added and Stopped CUDA:::Tesla_C1060.domain_a:tex_cache_hit successfully."

I believe the problem is occurring during the call to PAPI_cleanup_eventset() which occurs in the subroutine check_event in the all_native_events.c file.

I note that in the README file for PAPI components, under cuda/ it says: "..., the user has to call PAPI_cleanup_eventset( EventSet ) before calling PAPI_shutdown() in the application." However, the HelloWorld.cu example does not demonstrate the use of this call. If a CUDA counter is used for EventName (e.g., char *EventName[] = {"CUDA:::Tesla_C1060.domain_a:tex_cache_hit"};) and PAPI_cleanup_eventset is added to the end of the HelloWorld.cu file (and the program is rebuilt), a segmentation fault occurs on my machine. However, the count given seems reasonable (0 for CUDA:::Tesla_C1060.domain_a:tex_cache_hit, 9 for CUDA:::Tesla_C1060:domain_b:instructions).

Questions:
1. Is this a known issue?
2. Is this an installation or configuration issue?
3. Is this an issue with using an older GPU?

I appreciate your help!


Additional information:
1. My compilation procedure was:
> cd <papi-root>/src/components/cuda
> ./configure --with-cuda_incdir=/usr/local/cuda/incude --with-cupti_incdir=/usr/local/cuda/extras/CUPTI/include --with-cupti_libdir=/usr/local/cuda/extras/CUPTI/lib64
> cd ../../
> ./configure --with-components=cuda
> make

2. My machine has 2 NVIDIA cards: a C1060 GPU and a Quadro NVS 295 that is used primarily as a video card. The Tesla is a compute capability 1.3, the Quadro is 1.1.
KotasCW
 
Posts: 3
Joined: Mon Aug 27, 2012 3:25 pm

Return to General discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron