CUDA Hello World, zero counts?

CUDA Hello World, zero counts?

Postby roblim1 » Tue Jan 13, 2015 6:59 pm

I am trying to configure PAPI 5.3.0 with CUDA 6.5 (also tried 5.5 and 6.0) on a Tesla K20c. When I run with event "cuda:::Tesla_K20c:domain_d:inst_executed" (as provided by papi_native_avail), I get zeroes as the final count value.

I've configured and installed PAPI as follows:
Inside /papi-5.3.0/src/components/cuda
./configure --with-cuda-dir=/usr/local/packages/cuda/6.5 --with-cupti-dir=/usr/local/packages/cuda/6.5/extras/CUPTI
Inside /papi-5.3.0/src
./configure --with-components=cuda --prefix=/my-local-dir/papi-5.3.0
make install

Any advice is greatly appreciated.
Posts: 1
Joined: Tue Jan 13, 2015 6:43 pm

Re: CUDA Hello World, zero counts?

Postby yarkhan » Thu Jan 15, 2015 12:41 pm

I have run the CUDA test in a setup similar to the one you describe.

Using PAPI 5.3.0 with CUDA 6.5.14 on a Intel Xeon with one Tesla K20c.
I got a counter value of 14.

tests> ./HelloWorld
Name cuda:::Tesla_K20c:domain_d:inst_executed --- Code: 0x4000002a
END: Hello World!
14 --> cuda:::Tesla_K20c:domain_d:inst_executed

When I ran the same test on a different machine with a Tesla K40c, I also got a counter value of 14.

You should confirm that the expected libraries are being loaded for papi, cuda, cupti (check LD_LIBRARY_PATH).
You could try some other CUDA counters from papi_native_avail to see if they also give zeros.
Since I don't see any failure for this test, I would need more details from your problem.

Please note that the PAPI 5.4.0 was released in Nov 2014. If you are working on a private distribution of PAPI, you may want to upgrade to that.

Posts: 12
Joined: Mon Aug 11, 2014 10:33 am

Return to Component PAPI (PAPI-C) (read-only)

Who is online

Users browsing this forum: No registered users and 1 guest