support nehalme ex

Open discussion of PAPI.

support nehalme ex

Postby ericlew » Wed Aug 24, 2011 9:00 am


My processor is Nehalem-ex X7550 , so I need kernel 2.6.34 or newer(as the PAPI doc said). My now linux version is CentOS5.3, 2.6.18. So I want to update the kernel to version 2.6.34 or 2.6.38, but I encount an error when input the command:

Error: no suitable patch found for kernel



+ Nehalem EX support requires kernel 2.6.34 or newer.
Posts: 2
Joined: Wed Aug 24, 2011 8:54 am

Re: support nehalme ex

Postby vweaver1 » Thu Aug 25, 2011 1:46 pm

Kernel 2.6.34 or 2.6.38 should have built in "perf_event" support. You do not need to patch the kernel with perfctr.
Just recompile PAPI with perf_event support enabled.
Posts: 50
Joined: Wed Feb 17, 2010 4:02 pm

Return to General discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest