Problem in patching kernel for papi-3.7.2

Open discussion of PAPI.

Problem in patching kernel for papi-3.7.2

Postby raghup » Tue Feb 09, 2010 5:07 am

Hi all,

I am relatively new to performance APIs. I tried installing papi-3.7.2 on a debian OS on one of my lab machines. It runs on kernel version 2.6.24-etchnhalf.1-amd64 (uname -r), and so I had to patch the kernel with perfctr-2.6.x as mentioned in the installation instructions. I followed everything, including creating a new entry for the new kernel in my grub's menu.lst - Everything seemed to be fine till now.

However, after applying the patch as directed, on reboot, I get the following error :

FATAL : could not open /lib/modules/2.6.24-perfctr/modules.dep : No such file or directory.
Begin : Running /scripts/init-premount ...
FATAL : could not open /lib/modules/2.6.24-perfctr/modules.dep : No such file or directory.
FATAL : could not open /lib/modules/2.6.24-perfctr/modules.dep : No such file or directory.


After that, I get the Busybox shell, initramfs command prompt.
Upon doing a "cat /proc/modules", I get a null set i.e. nothing at all.
I examined my /dev directory, and found that there are no files of the form sdbX at all. (My root is mounted at /dev/sdb1)

On the other hand, if I use the other (unpatched) kernel's image from grub, the system boots perfectly. Also, the file /lib/modules/2.6.24-perfctr/modules.dep exists, and I could locate it.

Here is a partial listing of my /boot/grub/menu.lst file :
title Debian GNU/Linux, kernel 2.6.24-perfctr
root (hd1,0)
kernel /boot/vmlinuz-2.6.24-perfctr root=/dev/sdb1 ro rootdelay=120
initrd /boot/initrd.img-2.6.24-etchnhalf.1-amd64
savedefault

title Debian GNU/Linux, kernel 2.6.24-etchnhalf.1-amd64
root (hd1,0)
kernel /boot/vmlinuz-2.6.24-etchnhalf.1-amd64 root=/dev/sdb1 ro
initrd /boot/initrd.img-2.6.24-etchnhalf.1-amd64
savedefault

title Debian GNU/Linux, kernel 2.6.24-etchnhalf.1-amd64 (recovery mode)
lock
root (hd1,0)
kernel /boot/vmlinuz-2.6.24-etchnhalf.1-amd64 root=/dev/sdb1 ro single
initrd /boot/initrd.img-2.6.24-etchnhalf.1-amd64
savedefault


I am clueless as to where I am going wrong. Any help is invaluable. Thanks.
raghup
 
Posts: 2
Joined: Tue Feb 09, 2010 4:42 am

Re: Problem in patching kernel for papi-3.7.2

Postby Dan Terpstra » Tue Feb 09, 2010 1:04 pm

Did you do a make modules_install in the kernel source directory? That might explain the fact that there is no /lib/modules/2.6.24-perfctr directory.
Dan Terpstra
 
Posts: 57
Joined: Mon Aug 24, 2009 5:42 pm

Re: Problem in patching kernel for papi-3.7.2

Postby raghup » Wed Feb 10, 2010 5:32 am

Hi Dan,

Yes I did 'make modules_install' as a part of rebuilding my kernel.After the build, just before reboot, I could navigate to the file /lib/modules/2.6.24-perfctr/*.
In fact, when I booted with my old kernel image after the install (Option 2 in my menu.lst snapshot above), I can still see it. However, when I boot with the patched kernel image, it fails. My guess is that the drive where my filesystem is mounted (/dev/sdb1) isnt getting intialised/loaded properly, and I am clueless as to how to proceed. What am I missing ?
raghup
 
Posts: 2
Joined: Tue Feb 09, 2010 4:42 am


Return to General discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron