PAPI 4.2.0 Fails "make test" on Intel Core i7-2630QM

Open discussion of PAPI.

PAPI 4.2.0 Fails "make test" on Intel Core i7-2630QM

Postby francesquini » Tue Dec 13, 2011 1:05 pm

Hello,

I'm starting to use PAPI now, and as a newbie I have some questions. After configuring and compiling with no errors I get the following output from "make test":

ctests/zero
80000034 PAPI_FP_INS is not available.
Test case 0: start, stop.
-----------------------------------------------
Default domain is: 1 (PAPI_DOM_USER)
Default granularity is: 1 (PAPI_GRN_THR)
Using 20000000 iterations of c += a*b
-------------------------------------------------------------------------
Test type : 1
PAPI_FP_INS : 47810264166936
PAPI_TOT_CYC : 183860549
Real usec : 66883
Real cycles : 133463693
Virt usec : 66819
Virt cycles : 53456000
-------------------------------------------------------------------------
Verification: PAPI_TOT_CYC should be roughly real_cycles
Error of 27.41%
zero.c FAILED
Line # 117
Error: validation

make: ** [test] Erro 1

When I try to run "make fulltest", for almost every test I got the following
./ctests/timer_overflow.c: 2: CreatePresetTbl.sh: not found
...
./components/coretemp/tests/coretemp_basic.c: 21: Syntax error: "(" unexpected
....
/components/cuda/tests/HelloWorld.cu: 10: Syntax error: newline unexpected
...


Although CreatePresetTbl.sh is on the same directory, when I run it, it gives:
emilio@xisto:~/papi-4.2.0/src$ ./CreatePresetTbl.sh
.TS
box, tab(&);
lt | lw(50).
=
./CreatePresetTbl.sh: 12: ./tests/avail: not found
.TE
emilio@xisto:~/papi-4.2.0/src$


I simply cannot make heads or tails of it. Any advice?

System info:

Intel Core i7-2630QM

emilio@xisto:~$ sudo lscpu
[sudo] password for emilio:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 2
Core(s) per socket: 4
CPU socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 42
Stepping: 7
CPU MHz: 800.000
BogoMIPS: 3990.93
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 6144K
NUMA node0 CPU(s): 0-7



emilio@xisto:~$ uname -a
Linux warp 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
francesquini
 
Posts: 1
Joined: Tue Dec 13, 2011 12:41 pm

Re: PAPI 4.2.0 Fails "make test" on Intel Core i7-2630QM

Postby vweaver1 » Tue Feb 07, 2012 6:09 pm

The PAPI_TOT_CYC error you get is likely because your CPU is doing some sort of frequency scaling or turbo boost that is changing the clock frequency while the test runs. This is normal.

The other error you get is because the PAPI tests run by running all files marked as executable in the ctests directory. It looks like somehow all of your C files got marked executable somehow.
vweaver1
 
Posts: 50
Joined: Wed Feb 17, 2010 4:02 pm


Return to General discussion

Who is online

Users browsing this forum: Bing [Bot] and 2 guests