installation related questions

Open discussion of PAPI.

installation related questions

Postby bravegag » Sun Dec 02, 2012 4:21 pm

Hello,

I tried porting my code to PAPI 5.0 coming from PAPI 4.2 and the PCs didnt work so I reverted my changes and will stay on 4.x for a while.

The problem is that after reverting my code back to version PAPI 4.2 I now get the API change error everywhere and while using my old code for PAPI 4.2:
/Users/bravegag/code/fastcode_trunk/code/test/benchmark.cc:118:27: error: invalid conversion from 'char*' to 'int' [-fpermissive]
/Users/bravegag/code/fastcode_trunk/code/test/benchmark.cc:118:27: error: too few arguments to function 'int PAPI_perror(int, char*, int)'

The only thing I can think off is that there are some installation left overs somewhere from version 5? btw I could not find any uninstall script? it is most needed for a project that releases incompatible versions often and would help avoid the guess work involved in cleaning up the system from old versions.

Many TIA,
Best regards,
Giovanni
bravegag
 
Posts: 5
Joined: Mon Jun 04, 2012 10:05 am

Return to General discussion

Who is online

Users browsing this forum: Google [Bot] and 2 guests