PLASMA 2.5.1 - multi-threaded library warning

Open forum for general discussions relating to PLASMA.

PLASMA 2.5.1 - multi-threaded library warning

Postby FrnVogt » Mon Jul 08, 2013 11:10 pm

All:

thank you for this wonderful tool!
I just installed PLASMA 2.5.1 and I am particularly interested in using the SVD including singular vectors. The first test looks correct but I get the (expected) warning that I did not link a multithreaded library. The options MKL and ACML are not an available on my Linux machine and I'd like to use ATLAS-3.10.1 or ATLAS-3.11.11. Is this an option and if so, how do I compile+link properly?

Your help is appreciated.
FrnVogt
 
Posts: 4
Joined: Mon Jul 08, 2013 10:54 pm

Re: PLASMA 2.5.1 - multi-threaded library warning

Postby mateo70 » Wed Aug 07, 2013 7:34 am

You can disable the warning by calling PLASMA_DIsable(PLASMA_WARNINGS) after initialization, that should be enough.
Mathieu
mateo70
 
Posts: 92
Joined: Fri May 07, 2010 3:48 pm


Return to User discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron