Plasma on Amazon EC2

Open forum for general discussions relating to PLASMA.

Plasma on Amazon EC2

Postby tog » Sat Jun 05, 2010 1:36 am

Hi,

I just tried to install Plasma on Amazon EC2 running Ubuntu server 9.10 using:

Code: Select all
python setup.py --prefix ./plasma_c1.medium/ --blaslib="-lf77blas -lcblas -latlas

I code a couple of failed items (see below). I am wondering if someone already met those errors and has a way to fix them ?

Guillaume

Code: Select all
------------------------- Complex ------------------------
 
 ---- TESTING CPOSV ...................... PASSED !
 ---- TESTING CPOTRF + CPOTRS ............ PASSED !
 - TESTING CPOTRF + CTRSM + CTRSM ... FAILED !
 - TESTING CGELS ... FAILED !
 - TESTING CGEQRF + CGEQRS ... FAILED !
 - TESTING CGEQRF + CUNMQR + CTRSM ... FAILED !
 ---- TESTING CGELS ...................... PASSED !
 ---- TESTING CGELQF + CGELQS ............ PASSED !
 ---- TESTING CGELQF + CTRSM + CUNMLQ .... PASSED !
 - TESTING CGESV ... FAILED !
 - TESTING CGETRF + CGETRS ... FAILED !
 - TESTING CGETRF + CTRSMPL + CTRSM ... FAILED !
 ---- TESTING CGEMM ...................... PASSED !
 
------------------------- Double Complex ------------------------
 
 ---- TESTING ZPOSV ...................... PASSED !
 ---- TESTING ZPOTRF + ZPOTRS ............ PASSED !
 - TESTING ZPOTRF + ZTRSM + ZTRSM ... FAILED !
 - TESTING ZGELS ... FAILED !
 - TESTING ZGEQRF + ZGEQRS ... FAILED !
 - TESTING ZGEQRF + ZUNMQR + ZTRSM ... FAILED !
 ---- TESTING ZGELS ...................... PASSED !
 ---- TESTING ZGELQF + ZGELQS ............ PASSED !
 ---- TESTING ZGELQF + ZTRSM + ZUNMLQ .... PASSED !
 - TESTING ZGESV ... FAILED !
 - TESTING ZGETRF + ZGETRS ... FAILED !
 ---- TESTING ZGETRF + ZTRSMPL + ZTRSM ... PASSED !
 ---- TESTING ZGEMM ...................... PASSED !
tog
 
Posts: 2
Joined: Sat Jun 05, 2010 1:32 am

Re: Plasma on Amazon EC2

Postby tog » Sat Jun 05, 2010 4:53 am

Hi

On EC2 m1.small & c1.medium instances on which I got those failures, the tests look like blocked. On a x86_64 instance m1.large, the installation and tests run fine.
What could be the problem on those "small" instances ?

Guillaume
tog
 
Posts: 2
Joined: Sat Jun 05, 2010 1:32 am

Re: Plasma on Amazon EC2

Postby Bilel » Sat Jun 05, 2010 6:00 pm

Guillaume,

Can you please provide the testing_results.txt file. It shows the details of the runs.
Bilel
 
Posts: 4
Joined: Thu May 21, 2009 7:14 pm


Return to User discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron