Seg Fault on PBLAS tests: OSX 10.6

Post here if you have some questions about the ScaLAPACK installer

Seg Fault on PBLAS tests: OSX 10.6

Postby GeoffRyan » Sat Jun 30, 2012 6:28 pm


I'm trying to get ScaLAPACK installed via the python installer on my Macbook (early 2011, osx 10.6.8). I'm using OpenMPI 1.6, compiled with gcc and gfortran 4.6.0. The setup with reference BLAS and LAPACK worked fine, but gets a segmentation fault during PBLAS testing when I try to use the native BLAS and LAPACK (-framework Accelerate). My setup call is:

./ --prefix=/Users/geoff/Coding/Libraries/scalapack_bundle/scalapack --mpiincdir=/opt/openmpi/include --mpibindir=/opt/openmpi/bin --mpif90=mpif90 --mpicc=mpicc --mpirun=mpiexec --lapacklib="-framework Accelerate"

Here's the full output of

Code: Select all
/Users/geoff/Coding/Libraries/scalapack_bundle/scalapack_installer_1.0.2/script/ DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import popen2
Setting up the framework
ScaLAPACK installer version (1, 0, 2)
MPI include dir is  /opt/openmpi/include
MPI bin dir is  /opt/openmpi/bin
mpif90 is  mpif90
mpicc is  mpicc
mpirun is  mpiexec
Install directory is... /Users/geoff/Coding/Libraries/scalapack_bundle/scalapack
Creating directory /Users/geoff/Coding/Libraries/scalapack_bundle/scalapack_installer_1.0.2/build
Build directory is... /Users/geoff/Coding/Libraries/scalapack_bundle/scalapack_installer_1.0.2/build
BLAS library is... 
LAPACK library is...  -framework Accelerate
Checking if mpicc works... yes
Checking if mpirun works... yes
Checking if mpif90 works... yes
Setting Fortran mangling... -DAdd_
Setting download command...
Checking availability of urllib... available
Testing urllib... working
Setting ranlib command... /usr/bin/ranlib
Detecting Fortran compiler... GNU
Detecting C compiler... GNU
C flags are...  -O2
Fortran flags are...  -O2
Selected loader flags (C main):
Selected loader flags (f90 main):
Selected NOOPT flags: -O0
AR flags are...  rc
Checking loader... works

  BLAS installation/verification
Checking if the provided LAPACK (-framework Accelerate ) contains BLAS
BLAS library is set to -framework Accelerate
Checking if provided BLAS works... yes
Using the BLAS library contained in LAPACK library -framework Accelerate

  Lapack installation/verification
LAPACK library is -framework Accelerate
Checking if provided LAPACK works... yes
Getting LAPACK version number... 3.1.1
Checking if provided LAPACK contains functions for test works... no

ScaLAPACK installer is starting now. Buckle up!
Downloading ScaLAPACK... Creating directory /Users/geoff/Coding/Libraries/scalapack_bundle/scalapack_installer_1.0.2/build/download
Installing  scalapack-2.0.2 ...
Writing done.
Compiling BLACS, PBLAS and ScaLAPACK... done
Getting ScaLAPACK version number... 2.0.1
Installation of ScaLAPACK successful.
(log is in  /Users/geoff/Coding/Libraries/scalapack_bundle/scalapack_installer_1.0.2/build/log/scalog )
Compiling test routines... done
Running BLACS test routines... done
Running PBLAS test routines...

PBLAS: error running PBLAS test routines xcpblas1tst

PBLAS: Command mpiexec -np 4 ./xcpblas1tst
[Helo:02490] *** Process received signal ***
[Helo:02490] Signal: Segmentation fault (11)
[Helo:02490] Signal code:  (0)
[Helo:02490] Failing at address: 0x0
[Helo:02490] [ 0] 2   libSystem.B.dylib                   0x00007fff81a991ba _sigtramp + 26
[Helo:02490] [ 1] 3   ???                                 0x000000010072d710 0x0 + 4302493456
[Helo:02490] *** End of error message ***
mpiexec noticed that process rank 0 with PID 2490 on node Helo.local exited on signal 11 (Segmentation fault).


I have tried using reference LAPACK and Accelerate BLAS, but it fails in the same way. Using the reference BLAS but Accelerate LAPACK gets a but further, but dies during the ScaLAPACK testing:

Code: Select all
Running (some) ScaLAPACK test routines...

ScaLAPACK: error running ScaLAPACK test routines xcqr

ScaLAPACK: Command mpiexec -np 4 ./xcqr
[Helo:19583] *** Process received signal ***
[Helo:19583] Signal: Bus error (10)
[Helo:19583] Signal code: Non-existant physical address (2)
[Helo:19583] Failing at address: 0x100070d70
[Helo:19583] [ 0] 2   libSystem.B.dylib                   0x00007fff81a991ba _sigtramp + 26
[Helo:19583] [ 1] 3   ???                                 0x0000000000000031 0x0 + 49
[Helo:19583] [ 2] 4   xcqr                                0x0000000100054a67 pclarfg_ + 1895
[Helo:19583] [ 3] 5   ???                                 0x4920000100000001 0x0 + 5269211568318447617
[Helo:19583] *** End of error message ***
mpiexec noticed that process rank 0 with PID 19583 on node Helo.local exited on signal 10 (Bus error).


I've been looking through the archives, and some people with similar problems have pointed to this:, the (improper/non-standard/legacy?) implementation of zdotc, etc in the Accelerate framework. But this seemed to only come up with old hardware, is it still an issue on new(ish) macs? Any help would be much appreciated.

Posts: 1
Joined: Fri Jun 29, 2012 6:18 pm

Re: Seg Fault on PBLAS tests: OSX 10.6

Postby admin » Tue Jul 03, 2012 12:51 am

Yes some tests are failing with accelerate framework due to a bug in zdotc.
It is not fixed yet.
Double test should be fine though...
Site Admin
Posts: 616
Joined: Wed Dec 08, 2004 7:07 pm

Return to ScaLAPACK installer

Who is online

Users browsing this forum: No registered users and 1 guest