Inconsistent build results:Symbols not found for X86_64

Post here if you have a question about linking your program with LAPACK or ScaLAPACK library

Inconsistent build results:Symbols not found for X86_64

Postby FLorenzo » Tue Sep 03, 2013 5:43 pm

Dear members,

I have an application that uses Lapack and had implemented the use of the following functions: DSBEV, DSBGV, DGBSV, and tried to add the use of the Function DGESV.

However, when I add the lines to use DGESV the compiler gives me the infamous "symbols not found for architecture X86_64" . It works for all the other functions but not for DGESV.

I am building it for OSX and tried either -framework Accelerate or any of the other versions of LAPACK built by apple.

Oddly enough, if I write a simple code to use the DGESV function by itself, it builds and provides the required output.

Your help and input will be most appreciated.

F Lorenzo
Posts: 3
Joined: Wed Apr 27, 2011 10:09 am

Return to Linking Problem

Who is online

Users browsing this forum: No registered users and 2 guests