Linking Lapack and Blas with MSVS2013 in Windows 8.1

Post here if you have a question about linking your program with LAPACK or ScaLAPACK library

Linking Lapack and Blas with MSVS2013 in Windows 8.1

Postby allblues1001 » Sat Jan 31, 2015 6:36 am

Hello there experts,

I am trying to link my C code with Lapack and Blas libraries. I am using Microsoft Visual Studio 2013 on Windows 8.1 plateform. I have followed procedure on ... #libraries and copied the missing dll's libgfortran-3.dll and libgcc_s_dw2-1.dll in C:\Windows\System32 folder. Also did the linking and additional libraries steps in MSVS2013. The code gets compiled properly but when I try to run the executable, I fails to run giving error "The application was unable to start correctly (0xc000007b). Click OK to close the appllication". When I tried to run the same in debug mode. It gives the following error:

"Unhandled exception at 0x00007FF800A6C0B4 (ntdll.dll) in CubeArray.exe: 0xC000007B: %hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x."

This is something new for me as I was always able to get it worked on previous version of MSVS on Windows XP etc.

Any help would be greatly appreciated.

Posts: 1
Joined: Sat Jan 31, 2015 6:26 am

Return to Linking Problem

Who is online

Users browsing this forum: No registered users and 2 guests