building works, BLAS test fails

Post here if you have a question about the installation process

building works, BLAS test fails

Postby Kinderschokolade » Tue Dec 02, 2014 10:57 am


I am not sure if LAPACK actually works, I did something wrong or if I have a linking problem.

Here is what I did: I downloaded lapack 3.5.0 from netlib. The makefile is standard, then I did:
make lapackelib
make blaslib

And it finsihes with
Processing LAPACK Testing output found in the TESTING direcory
SUMMARY nb test run numerical error other error
================ =========== ================= ================
REAL 1079349 0 (0.000%) 0 (0.000%)
DOUBLE PRECISION 1080161 0 (0.000%) 0 (0.000%)
COMPLEX 556022 0 (0.000%) 0 (0.000%)
COMPLEX16 556834 0 (0.000%) 0 (0.000%)

--> ALL PRECISIONS 3272366 0 (0.000%) 0 (0.000%)

The libraries are copied to /usr/local/lib .

I tried to compile a program with
gfortran -lblas -llapack ev.f90
but I get:
ev.f90:(.text+0x8d4): undefined reference to `zgeev_'

So I thought it's a linking problem. Using
gfortran -L/usr/local/lib/ ev.f90
does not help.

I tried to run the LAPACK test program n the folder TESTING, but nothing happens when I try to run them (e.g. xeigtstc).
Same happnes for the BLAS test programs for level higher than 1. Level 1 is successful.

Does anyone know what's left to do?

Thank you!
Posts: 1
Joined: Tue Dec 02, 2014 6:20 am

Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests